This project is read-only.

After Installation, Page/Content Sites are empty

Topics: Installing Orchard
May 21, 2011 at 4:58 PM
Edited May 22, 2011 at 11:22 AM


I have just successfully installed Orchard CMS 1.1 on my host. But now when i log in as admin, and go to "Page" site or "Content" Site in the CMS, the site is just empty!

How can this happen? And how can i fix it? I can't add any content...

Also, on the homepage, the main content part is missing, i only see the 3 boxes "first leader aside", ..etc.


Here is the errolog i get:

2011-05-22 12:07:55,109 [5] NHibernate.AdoNet.AbstractBatcher - Could not execute query: SELECT this_.Id as Id12_0_, this_.SerialNumber as SerialNu2_12_0_ FROM Settings_ShellDescriptorRecord this_ WHERE 1=1System.Data.SqlServerCe.SqlCeException (0x80004005): The specified table does not exist. [ Settings_ShellDescriptorRecord ]   bei System.Data.SqlServerCe.SqlCeCommand.ProcessResults(Int32 hr)   bei System.Data.SqlServerCe.SqlCeCommand.CompileQueryPlan()   bei System.Data.SqlServerCe.SqlCeCommand.ExecuteCommand(CommandBehavior behavior, String method, ResultSetOptions options)   bei System.Data.SqlServerCe.SqlCeCommand.ExecuteDbDataReader(CommandBehavior behavior)   bei System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader()   bei NHibernate.AdoNet.AbstractBatcher.ExecuteReader(IDbCommand cmd)2011-05-22 12:07:55,234 [5] NHibernate.Util.ADOExceptionReporter - The specified table does not exist. [ Settings_ShellDescriptorRecord ]2011-05-22 12:07:55,250 [5] NHibernate.Util.ADOExceptionReporter - The specified table does not exist. [ Settings_ShellDescriptorRecord ]


May 24, 2011 at 9:13 PM

Apparently you have not successfully installed it. Can you try to start over?

Jun 1, 2011 at 7:11 PM

I have installed it a thousend times now, and i don't get it...

There are all files uploaded correctly, and the recipe has been "cooked" successfully..

I don't know what to do anymore... i would love to use this cms, but i can't!

Jun 1, 2011 at 7:24 PM

What database rpovider are you using? SqlCe or SQL Server? Which version? When you say you have tried several times, did you completely delete the database after each attempt? When you say "my host" do you mean a server at a hosting company? If so, does it work on your local machine? Can you describe in more details the procedure that you followed to install it?

Jun 2, 2011 at 4:46 PM

Well i've tried the newst Orchard version. I tried both the SQL Server and the SqlCompact but both with the same result.

I also checked if all files are on the server, and they are!

My host is a hosting company. They told me they think the problem is the security level, orchard needs a higher security level that they can give me on the server, but i can't believe that!

I have also a running installation on my local machine, which works lika a charm.


My installation steps:

1) upload files to server
2) give required permissions to folders 
3) open website, start installing ( it says "wait while recipe is beeing cooked...")
4) i get redirected to the site which looks like this:


Jun 2, 2011 at 8:25 PM

Unless they grant less than Medium Trust (in which case you should dump them), they are wrong. I cannot see a single reason why the app would be able to create widgets and everything but not the body of the page. Can't make sense of that error message. I'll ask around, but you might want to consider trying that on a different hosat. Who are they?

Jun 2, 2011 at 8:43 PM

The error log is normal, it's an excpected exception during setup. So the log is not explaining the issue at all.

Jun 3, 2011 at 4:27 PM

It's unbelievable...i found the mistake..

it was just one file my ftp program didn't upload ( i don't know why )

the file in /Core/Common/ was making all the problems..


anyways, thanks for help

Jun 3, 2011 at 8:48 PM

That would explain it :) Actually, it's scary how many failed deployments are because of errors in ftp transfer.