Email - SMTP Authentication - Password

Topics: Troubleshooting
May 2, 2011 at 7:39 PM

The Email settings page will not let me specify a password. I've selected "require credentials", I can type in a username and password but when i hit save I am greeted with what appears to be an empty error message container (see screen shot). I've tried a ton of different passwords, variations with and without numbers/symbols, nothing appears to pass the validation.

http://www.screencast.com/t/LJfkHkfDC

Coordinator
May 2, 2011 at 8:15 PM

Did you also fill all other inputs in the form ?

May 11, 2011 at 3:19 PM
Edited May 11, 2011 at 4:28 PM

Have you found a solution yet? I have the same problem. All Inputs are filled.  Maybe this information will help: It's a multi tenancy site. The default site is working.

Coordinator
May 11, 2011 at 5:35 PM
Edited May 11, 2011 at 5:37 PM

A few things that can happen:

* There is a firewall between the web server and the mail server blocking SMTP traffic
* The mail server has some restriction (such as SSL) that you didn't reflect in your settings

I know that on my own site, I couldn't get GMail to work and had to go through my hosting company's mail server.

In any case, the first step is probably to ask your hosting company what SMTP settings you should use. They deal with that sort of stuff every day.

May 11, 2011 at 6:58 PM

Thank you for help, but no, :(

the exact same settings work on the default "tenant" site. its an own exchange server in the same network.

Coordinator
May 11, 2011 at 7:03 PM

Ah sorry, I had missed the multi-tenancy bit. Sounds like a bug. Please file it in the issue tracker.

Coordinator
May 23, 2011 at 6:19 PM

I could not reproduce it even on another tenant. Could you look at the settings.txt file for this specific tenant  in App_Data\Sites\TENANT_NAME\, and verify there are values for EncryptionKey, HashAlgorithm and HashKey ?

May 24, 2011 at 6:36 AM

Hi, EncryptionKey, HashAlgorithm and HashKey is null:

 

Name: Reinke
DataProvider: SqlCe
DataConnectionString: null
DataPrefix: null
RequestUrlHost: lindenhof-reinke.de

RequestUrlPrefix: null
State: Running
EncryptionAlgorithm: null
EncryptionKey: null
HashAlgorithm: null
HashKey: null

Coordinator
May 24, 2011 at 5:36 PM

This is the issue. Those values should never be empty. How did you create your tenant ?

- By command line on by web interface ?
- What option did you choose, SqlCe, SqlServer, or "Up to the user" when creating the new tenant
- What version of Orchard are you using ?

Thanks

Coordinator
May 24, 2011 at 5:40 PM

Another one:

- What recipe are you using during Setup ?

May 25, 2011 at 7:38 AM
Edited May 25, 2011 at 7:40 AM

The default recipe. Its an upgraded Orchard version from 1.0.20 to newest (1.1.30).

 

The tenant is created AFTER the upgrade on the web interface. The option was SqlCe.

 

Another but functional tenant (Have the missing values) was created after the upgrade, too.

Coordinator
May 25, 2011 at 4:20 PM

Ok, new info. Are you able to reproduce it right now ? Is it blocking you / did you see my instructions on how to unblock you if so on the issue tracker ?

May 31, 2011 at 1:03 PM

I just came across this problem, too: The additional tenant had all Encryption and Hash settings set to null.

The tenant had been created by web interface, used the default recipe and I choose "sqlserver".

I didn't find a related ticket in the issue tracker.

Coordinator
May 31, 2011 at 3:19 PM

Is it a migration from 1.0 ?

May 31, 2011 at 3:43 PM

It was the latest 1.x-branch checkout -- without any migration. I started from zero (copied the contents of build/stage).

Jun 1, 2011 at 8:32 AM

I changed the host (DNS) setting of the tenant and now all 4 settings are null again.

Coordinator
Jun 1, 2011 at 7:32 PM

Ok, so you said changing a tenants dns prefix is deleting those values ... let me try it.

Coordinator
Jun 1, 2011 at 7:35 PM

GOT IT !

Thanks, that was it. No I can fix it ;)