Orchard 1.1 Just Stopped Working

Topics: General, Troubleshooting
Apr 14, 2011 at 1:55 PM

Came in today, refreshed my browser, and this is what I got when I was on the /Admin page...

HELP!

Server Error in '/' Application.

The IControllerFactory 'Orchard.Mvc.OrchardControllerFactory' did not return a controller for the name 'Account'.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidOperationException: The IControllerFactory 'Orchard.Mvc.OrchardControllerFactory' did not return a controller for the name 'Account'.

Source Error:

Line 141:                    throw;
Line 142:                }
Line 143:            }
Line 144:
Line 145:            [DebuggerStepThrough]


Source File: c:\Users\mplarsen\Downloads\orchard-48ba0ed3ac80\orchard_48ba0ed3ac80\src\Orchard\Mvc\Routes\ShellRoute.cs    Line: 143

Stack Trace:

[InvalidOperationException: The IControllerFactory 'Orchard.Mvc.OrchardControllerFactory' did not return a controller for the name 'Account'.]
   System.Web.Mvc.MvcHandler.ProcessRequestInit(HttpContextBase httpContext, IController& controller, IControllerFactory& factory) +721861
   System.Web.Mvc.<>c__DisplayClass6.<BeginProcessRequest>b__2() +71
   System.Web.Mvc.<>c__DisplayClassb`1.<ProcessInApplicationTrust>b__a() +19
   System.Web.Mvc.SecurityUtil.ProcessInApplicationTrust(Func`1 func) +161
   Orchard.Mvc.Routes.HttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData) in c:\Users\mplarsen\Downloads\orchard-48ba0ed3ac80\orchard_48ba0ed3ac80\src\Orchard\Mvc\Routes\ShellRoute.cs:143
   System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +389
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +371



Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.225

Coordinator
Apr 14, 2011 at 6:33 PM

Was this an upgrade from 1.0? Just guessing, but is there a possibility that this site is hosted on a farm and all servers are not in sync?

Apr 21, 2011 at 2:44 PM

Nope, this was a fresh install.

This happens at random, and it's really frustrating. There is NO WAY I'll be able to put this into production if this continues... I'd really appreciate any help you could give me.

Coordinator
Apr 21, 2011 at 3:34 PM

Is this on a web farm?
Do you think you could zip up the site and put it on DroBox or somewhere I can grab it and test?

Apr 21, 2011 at 3:35 PM

#### FIXED THE PROBLEM ####

I found this post: http://orchard.codeplex.com/discussions/253962

I followed what CraigMRoberts said to do, and this solved the problem. Odd...

 

@CraigMRoberts

I have analysed both my old Web.config file with a new one and the problem was on line 18. Instead of replacing the "Web.config" file just change the value of the "webpages:Enabled" to "false". Please see below for details.

 

Broken file

  <appSettings>
    <add key="webpages:Enabled" value="true" />
    <add key="log4net.Config" value="Config\log4net.config" />
  </appSettings>

 

Working File

  <appSettings>
    <add key="webpages:Enabled" value="false" />
    <add key="log4net.Config" value="Config\log4net.config" />
  </appSettings>

Apr 21, 2011 at 3:37 PM

@bertrandleroy - Thank you for following up with this and offering your help. I REALLY appreciate it. Your offer to assist me reassures me that choosing Orchard was the right thing to do!

Coordinator
Apr 21, 2011 at 6:10 PM

Do you have any idea how that flag got switched on?

Apr 22, 2011 at 8:01 PM

No clue! I wish I knew...

Jan 24, 2013 at 9:33 PM

I know, thread from forever back. But I'm extremely puzzled as to why this happens.

I just happened to run into this as well. All I did was create a HelloWorld module, added a web service reference, and added a layout for the projection module.

Maybe the OP did one of these as well, and the problem as to why this happens can be isolated.