Upgrade Problem

Topics: Installing Orchard, Troubleshooting
Apr 13, 2011 at 6:43 AM

Hi.

Following the instructions for a "clean update" I get the following error when trying to open the site:

CS1061: 'Orchard.Indexing.IIndexProvider' does not contain a definition for 'GetLastIndexUtc' and no extension method 'GetLastIndexUtc' accepting a first argument of type 'Orchard.Indexing.IIndexProvider' could be found (are you missing a using directive or an assembly reference?)

Any hints?

Apr 14, 2011 at 4:59 AM

I have the exact same problem.  Here is my repro:

1. Download Orchard 1.1.3 source from CodePlex - http://orchard.codeplex.com/releases/view/59918

2. Follow the Clean upgrade steps - http://orchardproject.net/docs/Upgrading-a-site-to-a-new-version-of-Orchard.ashx

3. Open the Orchard.sln in Visual Studio and attempt to compile. Result is the compiler error above.

 

Also, if you attempt to simply reach the site before trying to compile you will also get a compiler error.  

Coordinator
Apr 14, 2011 at 8:10 PM

If you are working from Visual Studio, ýou are probably using a source code enlistment, right? The upgrade instructions only apply for  the case of a standalone site, not a source code enlistment. I'll trry to make that clearer in the instructions.

Apr 15, 2011 at 5:25 AM

In my case I tried to upgrade a stand alone site and it didn´t work as well.

Coordinator
Apr 15, 2011 at 5:30 AM

You appear to have an incompletely migrated indexing module.

Apr 15, 2011 at 5:35 AM

Strange... for I´m only using the official releases. I tried to upgrade from 1.0.20 to 1.1.3.
Any hint what I can do to get rid of that error?

Coordinator
Apr 15, 2011 at 5:37 AM

I'm not saying that you are not using the right version, just that something seems to have gone wrong as you were copying that module over.

Apr 15, 2011 at 6:09 AM

Ok. I will download a fresh copy of 1.1.3 and try again. I will let you know the result.

Apr 15, 2011 at 6:35 AM

No, didn´t work. The only thing I can do is to install a fresh copy of 1.1.3, copy my Media, App_Data and my custom Themes and then step by step reinstall all the modules I used.

Apr 16, 2011 at 2:46 AM
Edited Apr 16, 2011 at 2:49 AM

I had similar problems to this.  My first problem came from Lucene.  First I tried just removing it and then I got that error on the Indexing, so I removed that, then an error on the Packing, so I removed that. and after that it all just fell apart.  I tried several times with doing things in different order and nothing seemed to work.  Eventually, I found a method that worked for me:

I installed a clean install then copied over the App_Data, Modules, Themes, and Media folders as specified in the upgrade docs.  Then, every time I got an error on a package, I just manually downloaded the .nupkg file from the Orchard Gallery, renamed it to .Zip and unzipped and copied out the content files and pasted them over top of the existing module files.  I think I went through four or five modules this way. That at least go me to a point where I could run the site. Then I tried to enable Recipes as specified in the upgrade docs and I got an exception on the Email module.  Following the steps above, I just replaced the Email module and then I was able to enable the Recipes module.  After this, I was able to follow the instructions and just upgrade modules as the docs say and it's all up and working now.

Maybe my experience was unique, but if nothing else works, you might try what I did.

Apr 16, 2011 at 4:01 AM

I've discovered the problem - a bug in the documentation.  It currently reads "Copy the additional module and themes directories that you have on your existing site into the new directory's Modules and Themes directories. (You can actually just copy the Themes and Modules directories over in their entirety.)"

Problem is you cannot just copy the Modules directory over in it's entirety, this is what I was doing that was causing the problem.  What you have to do instead is keep the new modules in 1.1 and only bring in the modules that you are using.  The way I did it was to follow the upgrade instructions exactly and then re-copy in the native 1.1 modules again, overwriting the ones from 1.0.2 that come in during the upgrade process.

If this solution works for you, please vote: http://orchard.uservoice.com/forums/50435-general/suggestions/1411809-upgrade-planning-don-t-break-old-modules?ref=title

Thanks!

Apr 16, 2011 at 4:23 AM

It turns out that you also have to do the above to the Themes directory as well.  The solution will still compile if you don't, but TheAdmin will throw a runtime error.  Again, I recopied the native 1.1 Themes over what was left from the upgrade and I'm back in business.

Thanks again!