(resolved) hosted post install dashboard widget area display fail

Topics: Installing Orchard, Troubleshooting
Mar 17, 2011 at 1:40 PM

I've used webmatrix to download and run local copies of Orchard. Works fine.

When I deploy to my web hosting company the site displays and navigates OK. However when I navigate to the Dashboard -> Widgets that display appears to be without css. The icon Images to edit the layers are broken and the Layers, Zones and available widgets all follow one another in one column rather than the three as displayed on the local test run.

I have deployed this as a .net 4.0 integrated pipeline and enabled write permissions. I've tried installing it with ce and SQL server. Same results. I deployed it with FTP from webmatrix. Webdeploy is not available.

Any suggestions I can offer my hosting provider?

Mar 18, 2011 at 6:07 PM

last night I used web deploy to publish this same site to a server 2008 r2 running iis 7.5 on my intranet. Worked fine as did the local web matrix test.

I wonder what I might have the hosting provider check to see if I can get this deployed successfully out in the _real_ world... ???

Coordinator
Mar 18, 2011 at 6:43 PM

You might want to focus on the stylesheet, which is what is not being served here. You can begin by looking up the URL for the stylesheet from view source in your browser, then open a new window and point it directly to that URL (or use a Firebug-like network tracing tool). That will give you an actual error message that could give you some info.

The local web.config in the Themes/TheAdmin/styles directory might be responsible. You should have one and it should be something like this:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <appSettings>
    <add key="webpages:Enabled" value="false" />
  </appSettings>
  <system.web>
    <httpHandlers>
      <!-- iis6 - for any request in this location, return via managed static file handler -->
      <add path="*" verb="*" type="System.Web.StaticFileHandler" />
    </httpHandlers>
  </system.web>
  <system.webServer>
    <handlers accessPolicy="Script,Read">
      <!--
      iis7 - for any request to a file exists on disk, return it via native http module.
      accessPolicy 'Script' is to allow for a managed 404 page.
      -->
      <add name="StaticFile" path="*" verb="*" modules="StaticFileModule" preCondition="integratedMode" resourceType="File" requireAccess="Read" />
    </handlers>
  </system.webServer>
</configuration>

Mar 18, 2011 at 9:22 PM

That's my web.config exactly.

I see no error when I access either of these.

http://www.jhalbrecht.com/Themes/TheAdmin/Styles/site.css

http://www.jhalbrecht.com/Themes/TheAdmin/Styles/images/icons.png

 

Mar 19, 2011 at 12:15 AM

Check out this like for a screen shot. http://is.gd/xWLkjt

 

Coordinator
Mar 19, 2011 at 12:31 AM

Ah, OK, so it's just for that specific admin page? Well, the one that's missing is neither of these, it's this one:

http://www.jhalbrecht.com/Modules/Orchard.Widgets/Styles/orchard-widgets-admin.css

You need to check what's wrong with that directory, the others work fine.

Mar 21, 2011 at 4:43 PM

The error I was getting was in refrence to Rejected-By-UrlScan  I sent my web hosting provider this link http://technet.microsoft.com/en-us/library/cc751376.aspx

This morning I received this message from them: Has anyone else seen this problem? Does my provider use elevated security while most other hosing providers use a less secure security policyt?

 

URLScan is IIS security. This URL is probably tripping it because the the . in Orchard.Widgets.:

                AllowDotInPath=0               ; If 1, allow dots that are not file

                               ; extensions. The default is 0. Note that

                               ; setting this property to 1 will make checks

                               ; based on extensions unreliable and is

                               ; therefore not recommended other than for

                               ; testing.

 

We can create special rules for your site if you don’t mind dropping IIS security. 
I created a directory Orchard_Widgets and now I get errors relating to a directory that 
doesn’t exist on this server: d:\TeamCity\Projects\Orchard-1.x\src\Orchard\Data\SessionFactoryHolder.cs


        
    
Mar 22, 2011 at 11:03 PM

I've been thinking about this, looking at the source code and watched http://weblogs.asp.net/bleroy/archive/2011/03/21/my-orchard-talk-for-lidnug.aspx By the way this talk has some great information about customizing themes and more...

It appears to me that many or all of the modules in Orchard.Web/Modules are named Orchard.Whatever if the problem with Orchard.Widgets was the . aren't there plenty of other modules executed earlier also with . in their name?

Anyone out there know someone that works in the IIS group at MS?

 

Mar 23, 2011 at 11:31 PM

I asked the hosting provider to drill down further into the logs. This is their reply:

"URLScan does not tell you specifically why it blocks, but you are still trying to make a call in a directory that has a . in it that URLScan will block."

 

Coordinator
Mar 24, 2011 at 12:03 AM
Edited Mar 24, 2011 at 12:31 AM

Yes, in Orchard there are directories with dots in their names that must be able to serve resources.

I'm investigating this.

Mar 24, 2011 at 8:53 PM

The widgets area is working corectly on the site. now. Thank you for the assistance.

I sent a link to an article http://technet.microsoft.com/en-us/security/cc242650.aspx suggesting the urlscan is not necessary in iis 6. I asked them to turn off urlscan on my site to which they replied:

"This server is running IIS7 with URLScan 3.1, URLScan is on with those rules by default. I disabled it on your sites "

Hope that doesn't open up to many security holes...

 

Coordinator
Mar 24, 2011 at 11:48 PM
Edited Mar 24, 2011 at 11:51 PM

Yes, I'd like to get to the bottom of this. I'll get back to you. But in the meantime, I'm glad you could be unblocked.

I logged http://orchard.codeplex.com/workitem/17544 to keep track of this.

Coordinator
Mar 26, 2011 at 5:14 AM

After investigation, AllowDotInPath is safe to set to true on an Orchard application.