Problem installing a module

Topics: Troubleshooting
Mar 15, 2011 at 9:34 AM

Watcha folks.

 

I was just browsing the gallery and came across Photo Albums V0.9.1 (http://www.orchardproject.net/gallery/List/Modules/Orchard.Module.Alexan.PhotoAlbums) I decided to download it install it from a site I am working on locally but the install failed. with the error

Error compiling module "Alexan.PhotoAlbums" from file "/OrchardLocal/Modules/Alexan.PhotoAlbums/Alexan.PhotoAlbums.csproj":Could not find file 'C:\Users\Nick\Desktop\Orchard sites\getphoto\src\Orchard.Web\Modules\Alexan.PhotoAlbums\Routes .cs'. 

After restarting the site I continue to get the error which is occurring  at Orchard.Environment.Extensions.Compilers.DefaultExtensionCompiler.Compile(CompileExtensionContext context)

I quickly set up a new project and tried to install the module again just to make sure it wasn't just some glitch on that attempt and I'm left with the same result.

 

The module hasn't installed locally but there must be some reference thats been added somewhere for this new module thats telling Orchard to look for it. Does anyone know where this would be so that I can remove it?

TIA

Nick 

Mar 15, 2011 at 9:48 AM
Edited Mar 15, 2011 at 1:53 PM

OK crisis averted. The Module had installed but there is a space in the file name of Routes .cs