(resolved) Freshly installed Orchard from .zip, setup screens not running.

Topics: Installing Orchard
Mar 14, 2011 at 8:39 PM

Hi there,

Just installed Orchard manually from the zip file. I'm running .NET 4.0. I installed the root of the zip right to the root of the website, and when going to the website after copying the files up, the configuration screens do not appear. It gives me a forbidden error stating that I don't have access to view the directory, like it should be finding a default.aspx page and is not. The way the project is setup is something I'm not familiar with. Should I be setting a default page for the install.sql or some other file?

Any help would be grand. This project looks fantastic and I'm looking to get involved.



Mar 14, 2011 at 9:28 PM

First thing to check is whether that web site is configured to run ASP.NET 4.0.

Mar 14, 2011 at 10:01 PM

Yeah, it's set for 4.0. That's what I meant by running .NET 4.0 (meant on the server). I tried making the install.sql a default page just for giggles, but that didn't work. I've installed MVC projects on this same server (it's a shared server, so I don't have direct access to the IIS Manager) with no problems, so it's not that either. I tried running the application locally to go through the setup phase then move it to the remote site after that. The DB setup fine (using a separate DB), but it still gives that same error like it can't find the default page... It should be picking it up from the Global.cs is what I'm figuring, right?

Thanks for the reply. Again, any help would be grand. Thanks much.


Mar 14, 2011 at 10:14 PM

Which zip did you download?

Mar 15, 2011 at 7:53 PM

I went to http://www.orchardproject.net/download and clicked on 'Download as a zip'.

Mar 15, 2011 at 8:22 PM

Where did you see an install.sql in there? Well, anyway, you don't need to run anything of the sort. It should just work out of the box if you follow the instructions from this page: http://www.orchardproject.net/docs/Manually-installing-Orchard-zip-file.ashx.

Can you give the exact error message you're seeing?

Mar 15, 2011 at 10:09 PM

Yeah, so here's the play-by-play. (I'm starting from scratch as I write this as well, just to do it all again in case I missed something.)

  • I downloaded the file that I referenced above and unziped it to my desktop.
  • The contents of the root of this folder are Orchard [directory], install.sql, manifest.xml, parameters.xml. In the Orchard folder are the typical files you expect from an .NET web project...
  • I uploaded the contents of this zip straight to my webserver root folder like the instructions say. So, the root of my webserver mimic the root of the zip file.
  • Then, when I go to the site it gives me the error, "403 - Forbidden: Access Denied. You do not have permission to view this directory or page using the credentials that you supplied." (You can take a look at it at http://www.allentrevethan.me if you want).

I'm holding right there. Let me know if you have any ideas, and I'll gladly try them. Thanks for all the help. I appreciate it!

Mar 15, 2011 at 10:19 PM

Aaaah, I see. Actually the instructions were relying on a previous layout of the zip file. This is an error on our part. All you need to do is use the contents of the Orchard folder within that zip rather than the root of the zip.

I'll fix the instructions. Sorry about that.

Mar 15, 2011 at 11:01 PM

No worries... I did, however, jump to that conclusion when I first tried to install it and received a 404 when trying that. I've changed it over on the site so you can see.

Mar 15, 2011 at 11:05 PM

Is it possible that it's the result of the default document manipulations you made before?

Mar 15, 2011 at 11:58 PM

I thought that also. The modifications I made was only to add install.sql as a default. I removed that today. Here are the default documents listed now:


Do you think it might have something to do with the Application Name? This is on a shared server, so I doubt my application space is named Defaul Web Site and I saw some references to that in the xml files in the root of the zip.

Mar 16, 2011 at 12:01 AM

Nothing comes to mind. Did you modify web.config? Did you try pointing WebMatrix at the same directory and see what happens?

Mar 16, 2011 at 12:19 AM

I don't have WebMatrix here to try that, but I did run it on the development server in Visual Studio and that worked fine... So, it's definitely a configuration problem of some sort... I haven't modified Web.config at all. I was going to look at that more closely today, but the last time I looked at it, it was all pretty straight forward. Not much there as far as specific configurations that jumped out at me as something of concern for a shared server setup.

I'm not too familiar with how Orchard is setup so I'm at a loss at really where to begin. Like if I were to trace what's going on behind the scenes. I was hoping you might be able to shed some light on that and point me in the right direction. I'm fairly new to MVC.Net as well, so that doesn't help. :) I don't see where the routes are configured in this setup. Where should the server be directing that first hit to start the setup pages?

Mar 16, 2011 at 12:22 AM

Ah, OK, so that does indeed rule out a few things. Maybe next thing to do could be to nuke it all and start over from scratch.

Essentially, what happens is that some bootstrapping is going on in global.asax, and then various modules contribute to the route table, including the setup module.

Mar 16, 2011 at 12:28 AM

Yeah, I just nuked it when I gave you the play-by-play (the third time I've done that). Could it have to do with the .me domain extension? Just a shot in the dark. There's no reliance on .com, .net, or .org in the code is there?

Mar 16, 2011 at 12:31 AM

HA! Now it's working... Grrrr. All I did was restart the web app... Chalk that one up to ghosts in the machine. :) Thanks for the help.

Mar 16, 2011 at 12:33 AM

Weird. Oh well. Sorry it took that much effort.

Mar 16, 2011 at 3:09 AM

hahah no worries. I guess it's the initial hazing of getting on a new CMS platform. :)

Apr 1, 2011 at 4:32 PM

Ok, took a bit of time off for real life... So, finally figured out what the problem was. My IIS was set for 4.0, and not 4.0 (Integrated Pipeline)... I think this is something with my host. I've not heard of the Integrated Pipeline before in pure .NET. Is this something I should be familiar with? :)

Apr 1, 2011 at 6:41 PM

:) Yes

Apr 1, 2011 at 7:01 PM

LOL :: reaches for Bing :: Thanks!!