This project is read-only.

Installation failed from Web Gallery using WebMatrix

Topics: Installing Orchard, Troubleshooting
Mar 11, 2011 at 3:37 PM
Edited Mar 11, 2011 at 4:27 PM

Just tried installing OrchardCMS using WebMatrix from the App Gallery.

Installation failed, the error message read:

Downloaded file failed signature verification and may have been tampered with.

Any suggestions, if it's something on my end to fix?




[Hold the phones - edit]: Looks like I have a Platform Installer update to upgrade to, maybe that will fix the issue.

Looks like I'm confused now, whether I'm to reinstall everything, doesn't WebMatrix have an upgrade path. If anybody's familiar with WebMatrix and how it installs orchard. I can also get Orchard using the Platform Installer, but want to be sure, my WebMatrix setup stays upgraded and the latest versions easily.


Sorry for the convoluted post here, looks like it's not actually finding the download this time or something it never starts downloading.


Ok tried installing everything from The Platform Installer, Orchard install still failed, WebMatrix went ok.

Next step I can try is trying it again in WebMAtrix, since it should be the latest version now.

Finally I could just create website from folder, really just a heads up then, in case something's messed up with the easy methods for total newbies.

Got an unknown error 12002 this time InternetOpenURL looks like a not found.

Thanks again.

Mar 11, 2011 at 5:50 PM
Edited Mar 11, 2011 at 5:58 PM

Ok, I have an install, you guys rock!

A note, when installing with WebMatrix:

  1. Extract the zip folder to your Site Root Folder
  2. When creating the site from a folder, you must point WebMatrix not at the extracted zip folder, but the folder within the Zip extract, simply titled Orchard
  3. Once you've done that click run and the site should launch

Still would like to know what happened to the other methods of installation, but in truth the manual version install couldn't be any easier.

Thanks Again!

tzOrchard 'Trix


Also would like to thank the team for the Contoso theme, it's a beauty.

Mar 11, 2011 at 8:14 PM

What happened the first time was very likely a bad download. You could have cleared the cache and tried again.

Mar 11, 2011 at 8:26 PM

WebMatrix created an error reporting file named install16.txt showing the location in my user's app data folder.



By clear cache you mean I would have deleted that temp file, and that was the likely suspected problem?

Possibly the download was interupted then maybe, I'm a constant multi-tasker, read ADD syndrome, lol.

Mar 11, 2011 at 8:29 PM

Well, clearing the WebPI cache is kind of a mess, but this is what I meant: (last section)

Mar 11, 2011 at 8:38 PM

thanks Bertrand, likely you are right, I was able to navigate to that cache appdata folder, and found an orchard zipe file that was only  about 1,700kb, so the download never completed.

Nice to know how to scrape out the old cache, I'm guessing you're chosen tool is a command line solution?

Where it said... 
Cleaning the Web PI Cache:
Web PI is caching the product catalog and other files to optimize startup time.
If the product catalog seems to be outdated or if incorrect data is displayed in Web PI, delete the cache with:
del /q "%localappdata%\Microsoft\web platform installer\*" 

Homie don't do command line, lol.

thank you very much for your responses.