Error on setup

Topics: Installing Orchard
Mar 9, 2011 at 6:26 PM

Hi all my name is Lance, this is my first post to the forum. I have the following error after cloning and trying to setup:

None of the constructors found with policy 'Autofac.Core.Activators.Reflection.BindingFlagsConstructorFinder' on type 'Orchard.Environment.DefaultOrchardShell' can be invoked with the available services and parameters: Constructor 'Void .ctor(System.Func`1[Autofac.Features.OwnedInstances.Owned`1[Orchard.Environment.IOrchardShellEvents]], System.Collections.Generic.IEnumerable`1[Orchard.Mvc.Routes.IRouteProvider], Orchard.Mvc.Routes.IRoutePublisher, System.Collections.Generic.IEnumerable`1[Orchard.Mvc.ModelBinders.IModelBinderProvider], Orchard.Mvc.ModelBinders.IModelBinderPublisher)' parameter resolution failed at parameter 'Orchard.Mvc.Routes.IRoutePublisher routePublisher'.

Anyone know what the problem could be?

Mar 9, 2011 at 7:05 PM

Did you configure the IIS application pool to run .NET 4.0?

Mar 9, 2011 at 9:26 PM

Actually we got past this error and are now struggling with:

Parameter cannot be null: Name = service key.

This usually happens when we forget an entry in the Routes.cs file in our modeule but this is not the case this time. Orchard is actually not finding it's own default route.

Got any ideas?

Thanks for the reply.

Mar 9, 2011 at 9:29 PM

And you're seeing that error when you do what?

Jul 9, 2011 at 8:03 PM

I have the same problem ! is there any solution for this issue ?

Jul 11, 2011 at 9:22 PM

Then can you answer the question I asked?

Jul 11, 2011 at 9:23 PM

Hold on, let me look at the thread.

From: bertrandleroy [email removed]
Sent: Monday, July 11, 2011 4:23 PM
To: Lance Barger
Subject: Re: Error on setup [orchard:249079]

From: bertrandleroy

Then can you answer the question I asked?

Jul 12, 2011 at 5:58 AM

Finally i Fixed it.

You must to set the write permission for all over your site !

I don't know why but it's working.