Re-authentication and logging (solved)

Topics: Administration, Installing Orchard
Feb 28, 2011 at 12:58 PM
Hello, I am hoping someone may be able to shed some light on what’s happening and might fix it or at least provide me with some instruction on how I might enable logging to determine where the fault is happening. I have ftp’d the orchard site (manual install) to the root of my site and every time I try to do something that requires administrative permissions such as creating a new user, adding a new page, ect. It am prompted with the sign in page after each and every operation. I have tried this on a brand new site with asp.net 4.0, full trust.
Coordinator
Feb 28, 2011 at 6:56 PM

Are cookies enabled on your browser?

Mar 1, 2011 at 2:44 AM

hi Bertrandleroy, thank you for the reply. yes, I do have cookies enabled. I have used IE 7 and firefox and I recived an error today ( see below ). I'm starting to wonder if i missed a file or there are some directory permissions missing or not set properly. but as i said before, it seems to authenticate me, it's just each and everytime. I noticed that some people were having some issues with a shallow app pools. i belive mine is capped at 200mg which i thought was pretty large?

Module

BasicAuthenticationModule

Notification

AuthenticateRequest

Handler

NotFound

Error Code

0x8007052e

Requested URL

http://{ mysite.com} /Admin/Contents/Edit/13?ReturnUrl=%2Ftest

Physical Path

{ physical path} \Admin\Contents\Edit\13

Logon Method

Not yet determined

Logon User

Not yet determined

 

thank you again for your help.

Coordinator
Mar 1, 2011 at 4:02 AM

Yes, possibly, it may be caused by some constraints on the host. Do you think you could contact the hosting company and ask them if they have traces in their logs of what happened?

Another test you can do is deploy the same site to your dev machine and see if it reproduces.

Mar 18, 2011 at 1:25 PM

Hi Bertrandleroy, it appears that once i added a custom machinekey, everything works very well. i suspect as another user pointed out in the general forum that the app pool was being recycled at 100mb. I have a 200mb ceiling?! not quite sure why this is, but now i can start playing. thanks for your help.

Apr 7, 2011 at 9:02 AM

Hi,

I had the same problem and solved it too by adding a custom machinekey. Took me a while to figure out, though. Good I found this post.