This project is read-only.

Can't remove tags from tags page

Feb 4, 2011 at 11:15 AM

I'm trying out Orchard on a new website and so far it seems pretty good. There's one thing that's causing me some bother though and that's that I can't remove any tags. I can create them and edit them but whenever I try and remove them through the tags page it generates the following error:

Type mismatch in NHibernate.Criterion.SimpleExpression: TagRecord expected type Orchard.Tags.Models.TagRecord, actual type Orchard.Tags.Models.TagRecord


If I delete the blog post that the tag is associated with the tag gets removed without any issues, it only seems to occur on the tags page. I'm currently using the SQL Compact database anybody got any ideas?

Feb 4, 2011 at 6:54 PM

That's weird, I just tried it and it worked. Could you please provide the exact steps you followed to get to that result?

Feb 4, 2011 at 7:16 PM

This is really annoying, I've now tried it on my home PC and it's now working fine!

I'll try and replicate it again when I'm back in the office.