Activate Image Slider Contoso Theme

Jan 31, 2011 at 2:01 AM

How to configure Orchard / the Contoso Theme 1.0 with the Image Slider, as it is displayed in the Preview at the Download Page?

Thanks in advance.

Jan 31, 2011 at 6:32 PM


What you want to do is is look in the instructions.txt file that included with the Contoso theme. There you should be able to find the code to use and to modify as you see fit. In short, what you have to do is create an HTML Widget and paste in the code that is included in the instructions.txt file. Then place that widget into the Home Featured Image Zone and on the HomePage layer so it only shows up on the homepage. That should be all you need to get it going.

Jan 31, 2011 at 8:28 PM

Hi, thanks for your Help - it works like a charm!

Feb 11, 2011 at 9:03 AM

Hello Mibach

this is the first time i will work with orchard.
I have the Image Slider install about the description in the instruction file. The first image ist displayed but but it doesn't work. The button on left and right side are not show.
This is my code in the HTML Widget ( from the instructions.txt file)
<script src="Themes/Contoso/Scripts/easySlider.js" type="text/javascript"></script>
<script type="text/javascript">// <![CDATA[
                $(document).ready(function() {
                        prevText: '',
                  nextText: '',
                  speed: '1600',
// ]]></script>
<div id="slider">
<li><img src="Themes/Contoso/Content/Images/Gallery/feature01.jpg" alt="Orchard Rocks" /></li>
<li><img src="Themes/Contoso/Content/Images/Gallery/feature02.jpg" alt="Orchard FTW" /></li>
<li><img src="Themes/Contoso/Content/Images/Gallery/feature03.jpg" alt="Orchard Time" /></li>
<li><img src="Themes/Contoso/Content/Images/Gallery/feature04.jpg" alt="Orchard Test" /></li>

 Thank you for Help


Feb 11, 2011 at 9:42 AM

try to put a HTML Widget to the Header Zone at the Hompage Layer:
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
Clear your Browser Cache and restart the Browser.
I had the same Problem and this works for me.

Feb 11, 2011 at 11:51 AM

Hi Mischka

i have put a HTML Wiget to the Header Zone and our string into the HTML Source Code.
The Cache is clear, but it doesn't work after restart the Browser.
I work with IE 9 and Win7, but on the Homesite of Orchard Website, the  Image Slider work perfect.

I will test on my personal PC at the weekend.

Thank you at first.


Feb 15, 2011 at 7:51 AM


i have test die Image Slider on my personal PC at home but i have the same situation, the Image Slider doesn't work. I use WebMatrix to open the Orchard Wesite on the local machine.
If i try the HTML Widget to the Header Zone an put in the HTML Source your String and push the update buttom the is no content. When i edit the HTML Widget again and open the HTML Source, i can not see any string.
Can some one help me???????


Feb 15, 2011 at 7:52 PM

Here is what I've done:



HTML Widget Home Featured Image Zone @ the Homepage:

<!--                 $(document).ready(function() {                     $("#slider").easySlider({                         prevText: '', 		                nextText: '', 		                speed: '1600',                     });             }); // -->
<div id="slider">
<li> <a title="Lernschmiede Kernnetzwerk" href="/uebungsnetzwerk"><img src="/Media/Default/TeaserPics/Lernschmiede_Kernnetzwerk_Full_teaser.png" alt="Lernschmiede Kernnetzwerk" /></a></li>
<li> <a title="Internetserever" href="/internetserver"><img src="/Media/Default/TeaserPics/Lernschmiede_owa_teaser.png" alt="Internetserver" /></a></li>
<li> <a title="Lernschmiede Mobil" href="/lernschmiede-mobil"><img src="/Media/Default/TeaserPics/Lernschmiede_Mobil_Teaser.png" alt="Lernschmiede Mobil" /></a></li>
HTML Widget Header Zone @ the Homepage:
Result at the testing Playground:
Feb 22, 2011 at 1:12 PM

Hi together

i have test the Image Slider at home on my personal pc. The Image Slider does not work with IE 9 RC. If i use the Opera browser on the same system, the Image Slider works perfectly.
Second test. Install WebMatrix and Orchard on my Notebook with Win XP and IE 8. Config the Image Slider and see there, it works as intended.

Does anyone have an idea why the image slider not working properly in IE 9 RC?

I tried the String <meta content> of Mischka as described, without success.



Apr 20, 2011 at 12:19 AM

I'm having the same issue Markus...just to confirm.

Apr 20, 2011 at 6:47 AM

Hi riversbendlodge

with the new release 1.1.30 the image slider works perfect in Windows 7 64 bit and IE 9.
I have install the new releas of Orchard yesterday an test the image slider at first time.

Happy days over Eastern




Apr 26, 2011 at 10:24 PM

thanks shinaiman...i'm runing IE9 on Win7 32 bit. I updated to 1.1.30 and the image slider still does not work. i've tested in opera win7 32bit as well.

the source code of the loaded page has the following easyslider code generated...there is no reference to the easyslider.js file; basically, it source code being generated doesn't look anything like what is on the home page of



div id="layout-home-featured" class ="group">


<div id="layout-home-featured-image">  <div class="zone zone-home-featured-image"> <div class="widget-control"> 

<div class="manage-actions"><a href="/Admin/Widgets/EditWidget/46?ReturnUrl=%2F">Edit</a></div>



<article class="widget-html-widget widget"><!-- $(document).ready(function() { $("#slider").easySlider({ prevText: '', nextText: '', speed: '1600', }); }); // -->


div id ="slider">


ul >


li><img src="/Media/Default/images/feature01.jpg" /></li >


li><img src="/Media/Default/images/feature02.jpg" /></li >


li><img src="/Media/Default/images/feature03.jpg" /></li >


ul >


div></article >


Apr 27, 2011 at 11:19 AM

Hi riversbendlodge

i have activated the kompatibilitäts modus in IE 9, the slider works.

Best regards