Multi Tenant Site Setup

Jan 28, 2011 at 5:41 AM

I followed http://orchardproject.net/docs/Setting%20up%20a%20multi-tenant%20Orchard%20site.ashx after installing Orchard CMS using the IIS option on my windows 7 machine.

My hosts file has domain1.local and domain2.local in it setup to point at 127.0.0.1.

One Website has been setup with both domain names in the bindings.

After downloading, installing and enabling Multi Tenancy, I created a new tenant for domain2.local

I then click on setup for the domain2 and get a 404.

Any ideas?

Jan 28, 2011 at 7:12 AM

Something I encountered with Multi tenancy in the past was that when I create a tenant with a space in the tenant name I encountered this and other errors. If this is the case with you as well ensure you create a tenant with no spaces or other funny characters in the tenant name. 

Jan 30, 2011 at 7:45 PM

Thanks for that, I have checked and can confirm that I am not using anything other alphabet characters in the site name, host name and default for the tables.

I have used a simple example to make sure it works first.

It would be cool if someone could verify that the above simple setup works for them.

Maybe the problem is my iis settings on my windows 7 machine?

Regards

Jan 31, 2011 at 12:39 PM

If you check the url of the setup link for the new tenant when you using http://domain1.local/ you may find it is not what you expect depending how you set host in Multi Tenancy.

If both domains are in the host file and the bindings in IIS config you should be able to type http://domain2.local/ in the browser address bar and continue the setup.

if you get your existing domain1 web site (default) it is because Orchard has not matched the Multi Tenancy host to the IIS host name.

Suggest you use domain2.local without http:;/ or trailing / for the Orchard Multi Tenancy host

Feb 1, 2011 at 5:36 AM

Ok, worked it out. My bindings were not as configured incorrectly in IIS.

Once I configured IIS to match my local dns settings in my hosts file, it all started to play nice.

Thanks for the help.