List as Home Page

Jan 24, 2011 at 3:50 PM

When I create a list of custom content type, it doesn't display anything when set as the homepage.  Is this a bug, or am I doing something wrong here?

Jan 24, 2011 at 8:38 PM

Did you put any content items under that list?


Jan 24, 2011 at 9:36 PM


Jan 24, 2011 at 9:39 PM

I should probably have stated that this list works fine when not set as the home page.  When set as the homepage, content items don't display.

Jan 24, 2011 at 10:27 PM

Do you have multiple pages/content/etc set as the home page? I ran into little issues like when I create another page and set it to be the home page when I already have a home page currently active. There isn't any validation for it from what I've seen.

Feb 5, 2011 at 12:32 PM

I have run into the same problem. Created a content part that is attachable and it does not display in a list on the homepage. If I create a menu item for the list, all items show. Any ideas?

Feb 5, 2011 at 9:41 PM

When you promote a list to the home page technically its slug changes. This may be what causes the list to lose its contents as it doesn't know what to display anymore. Can you please file a bug for that in the issue tracker? we have some work on lists that is scheduled soon and I'd like this to be part of it.

Mar 8, 2011 at 1:34 PM
Edited Mar 8, 2011 at 1:35 PM

I ran into this issue as well.  It doesn't appear to be the empty slug that's the problem, but rather the fact that the routing engine and the view engine aren't able to identify the appropriate area for the List.  When a List is displayed as its own page, the area in the RouteData collection is "Containers", and consequently the Orchard.Core.Containers.Controllers.ItemController controller and the Core\Containers\Views\Item\Display.cshtml view are used.  However, when the List is set as the home page, the area is "HomePage", and the Orchard.Core.Routable.Controllers.ItemController controller and the Core\Contents\Views\Item\Display.cshtml view are used.

I've tried adding a ContainerPartHandler to the Containers module and overrode the GetItemMetadata() method to provide route metadata to the routing engine (similar to the pattern used for the BlogPartHandler), but haven't been able to nail down the solution quite yet.

Apr 22, 2011 at 7:57 AM
Edited Apr 22, 2011 at 8:00 AM

Have anyone found a solution for this issue? It's still bugging people (namely me =))

Apr 22, 2011 at 2:14 PM

Did you install 1.1?  I don't know if they fixed it in the newest version or not, but it's worth a try.

Apr 22, 2011 at 2:17 PM

I made a clean install of the latest version yesterday and the bug is still there, unfortunately.

Apr 22, 2011 at 7:50 PM

Has anyone filed a bug on that?

Apr 22, 2011 at 7:54 PM

If I remember correctly, I went to do it, but someone had already filed one.

Apr 23, 2011 at 8:00 AM
Edited Apr 23, 2011 at 8:01 AM

The bug in the issue tracker: . And here comes a newbie question: does 'file a bug' requires attaching file with exported site providing example of the bug as well? Because currently I don't see one there. I can do it, if it's needed (though the way to reproduce the bug is very simple and has already been described, both here and on the issue page).

Apr 23, 2011 at 11:54 AM

Filing a bug just means adding it to the issue tracker. As long as there's enough information to reproduce / understand the problem, it's fine.