ClickToBuildAzurePackage.cmd ... Error: The OutputPath property is not set

Jan 22, 2011 at 11:58 PM

 

A copy of my (unanswered) post at:  http://orchardproject.net/docs/Deploying-Orchard-to-Windows-Azure.ashx?Discuss=1

The instructions are explicitly perfect ... but "... not on my machine" 

Compiles and runs from VS IDE just fine ... but .....

c:\Projects\OrchardAzure>ClickToBuildAzurePackage.cmd

c:\Projects\OrchardAzure>if "C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A \" NEQ "" goto build

c:\Projects\OrchardAzure>msbuild /t:Build AzurePackage.proj Microsoft (R) Build Engine Version 4.0.30319.1 Microsoft .NET Framework, Version 4.0.30319.1 Copyright (C) Microsoft Corporation 2007. All rights reserved.

Build started 1/22/2011 3:26:16 PM. Project "c:\Projects\OrchardAzure\AzurePackage.proj" on node 1 (Build target(s) ). C:\Windows\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(490,9): error : The OutputPath property is not set for this project. Please check to m ake sure that you have specified a valid Configuration/Platform combination. C onfiguration= Platform='MCD' \Projects\OrchardAzure\AzurePackage.proj Done Building Project "c:\Projects\OrchardAzure\AzurePackage.proj" (Build targe t(s)) -- FAILED.

Build FAILED.

"c:\Projects\OrchardAzure\AzurePackage.proj" (Build target) (1) -> (_CheckForInvalidConfigurationAndPlatform target) -> C:\Windows\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(490,9)
error : The OutputPath property is not set for this project. Please check to
make sure that you have specified a valid Configuration/Platform combination. Configuration=
Platform='MCD' \Projects\OrchardAzure\AzurePackage.proj

0 Warning(s) 1 Error(s)
Coordinator
Jan 23, 2011 at 6:30 AM

Do you have Azure SDK 1.3 installed ? And also Azure Cloud services ?

Jan 23, 2011 at 3:29 PM

yes ... and I just uninstalled / re-installed and got the same error ... ( interesting that the project builds OK in the VS IDE even when the SDK and CloudSvcs are UNINSTALLED ??!!)

doesn't this:

Project "c:\Projects\OrchardAzure\AzurePackage.proj" on node 1 (Build target(s) ). C:\Windows\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(490,9): error : The OutputPath property is not set for this project. Please check to m ake sure that you have specified a valid Configuration/Platform combination.

indicate that the AzurePackage.proj below in RED doesn't know where to put the compiler output ( no bin directory specified ??) ... is that something that I can change from the VS IDE ????

c:\Projects\OrchardAzure>type ClickToBuildAzurePackage.cmd

if "%WindowsSdkDir%" neq "" goto build
if exist "%ProgramFiles(x86)%\Microsoft Visual Studio 10.0\VC\vcvarsall.bat" g
o initialize2k8on64
if exist "%ProgramFiles%\Microsoft Visual Studio 10.0\VC\vcvarsall.bat" goto i
tialize2k8
echo "Unable to detect suitable environment. Build may not succeed."
goto build


:initialize2k8
call "%ProgramFiles%\Microsoft Visual Studio 10.0\VC\vcvarsall.bat" x86
goto build

:initialize2k8on64
call "%ProgramFiles(x86)%\Microsoft Visual Studio 10.0\VC\vcvarsall.bat" x86
goto build


:build
msbuild /t:Build AzurePackage.proj
pause
goto end


:end

 

Jan 23, 2011 at 8:39 PM

doing this on a Windows7 machine ... could that be a factor ???

/s

Feb 28, 2011 at 12:46 PM

I'm having the exact same issue. Has there been any resolution?