Bad error

Jan 19, 2011 at 7:18 AM

Apparently when I tried to install the Email module, something aborted during the process.  Now I can view the site, but I can't get into the Admin area at all.  I get the error:

Invalid object name 'orchard_Orchard_Email_SmtpSettingsPartRecord'.

Presumably it updated the system saying that the module wasn't installed, but never finished creating the tables.  First off, that sounds like a bug.  Second, can I get some steps to back this out so I can try the install again?

Help!!

-=Arian

Coordinator
Jan 19, 2011 at 7:39 AM

1) The bug: yes, it sounds like a bug (although it didn't occur on my machine). Would you mind looking at the error log files (App_Data\Logs) and sharing?

2) Recover: Try renaming the "~/Modules/Orchard.Email/Module.txt" file (e.g. Module.txt.bak). This will prevent the module from being loaded by Orchard.

Jan 19, 2011 at 8:36 AM

Wow!  Fast response!  The renaming did the trick in terms of disabling it.  When I tried to reinstall it, I got the exact same problem.  If it can't be recreated, any thoughts on why I might be seeing it?