Permissions issues on GoDaddy

Jan 17, 2011 at 10:22 PM

I've successfully installed and configured my site, but I can't install modules or themes.  I've tried several times to install one from the gallery but I get the following error:

Package installation failed.
There was an error installing the requested package. This can happen if the server does not have write access to the '~/Modules' or '~/Themes' folder of the web site. If the site is running in shared hosted environement, adding write access to these folders sometimes needs to be done manually through the Hoster control panel. Once Themes and Modules have been installed, it is recommended to remove write access to these folders.
Request for the permission of type 'System.Net.WebPermission, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

I've used the GoDaddy file manager and set permissions on every single file/folder on my site, but I still get that error.  I've tried deleting and recopying, but it doesn't help.  I even had GoDaddy check the file permissions directly on the server but they say that they are all write-able as they should be.  What else could cause this error?

 

Thanks!

-Arian

Coordinator
Jan 17, 2011 at 11:05 PM

A couple of things:

1. The "real" error message is the last one (Request for System.Net.WebPermission ...". The message above is a generic message we display whenever a package installation failed.

2. I had the exact same problem on my Godaddy account yesterday. It worked 3 days ago, then stopped working with the exact same error, but it is working again today (as of 5 mins ago). I think they might have issue with the configuration of their machines. Here is what they say about Medium Trust support: http://help.godaddy.com/article/1039

Using a Medium trust level prevents applications from accessing shared system resources and eliminates the potential for application interference. Adding OleDbPermission and OdbcPermission allows applications to use those data providers to access databases. WebPermission is modified to allow outbound http and https traffic.

Note the last sentence about WebPermission added to allow outbound http traffic. I believe this is what the Gallery module needs to download packages.

Jan 18, 2011 at 12:44 AM

This would indicate that it should work though, right?  Do I need to explicitly set permissions, or would it be at the machine.config level?  The KB article seems to imply it's already in place.

Coordinator
Jan 18, 2011 at 12:48 AM
Edited Jan 18, 2011 at 12:48 AM

Yes, it should work "out of the box".

What I am saying is that on my GoDaddy account, package downloading was working 3 days ago, stopped working yesterday (with the same error you are describing) and started working again today. I didn't change any configuration setting (anything in the site really) in the past week, that's why i'm saying it might be the GoDaddy people playing with the configuration of their servers. So, it might be worth a try contacting them and asking about this "System.Net.WebPermission" issue.

Jan 18, 2011 at 12:51 AM

I think I've got it.  You do need to explicitly add some code.  In web.config, search for the <system.web> block and add the below <trust> block before the <httpRuntime> element:

 

 <system.web>

<trust level="Medium" originUrl="" />

<httpRuntime requestValidationMode="2.0" />

 

Coordinator
Jan 18, 2011 at 1:05 AM

That's weird, i don't have that entry.

To install Orchard on that account, I basically uploaded "Orchard.Web.1.0.20.zip" to my account, extracted it using their file manager tool. I then gave write acces to "App_Data", "Media", "Modules" and "Themes" using the same file manager tool. Once this was done, i simply navigated to the site homepage, which got me to the Orchard setup screen, which finally led me to the Orchard admin panel. At that point, i could install packages from the gallery without problem (except for yesterday :-))

Maybe we use different types of plan? I use the "Deluxe" $7.99/month plan... (I use this for testing only :))

Jan 19, 2011 at 7:06 PM

This could be helpful to others possibly, or maybe I'm just weird.  :-(  I'm getting timeouts on a big portion of page requests, and lots of "file in use" lock errors.  I called GoDaddy and their suggestion (after talking to two higher-level tech people) was to upgrade to dedicated or virtual dedicated.  Hardly a solution!

 

I'm on Windows/Shared Hosting (Economy), ASP.NET 4.0, IIS 7.0, Integrated pipeline mode, SQL Server 2008 w/DSN installed (though using connection string), on an external facing server (so I can use SQL Server Management Studio).

 

Using SSMS, I haven't seen any timeouts at all, yet the logs in App_Data are quite full of them.

 

Anything else I can check?  I got file lock errors with Subtext all the time too, though no database timeouts.

Coordinator
Jan 19, 2011 at 7:14 PM
Edited Jan 19, 2011 at 7:15 PM

I've had similar problems with my hoster (not GoDaddy) that they were able to fix with some tweaks to their web farm settings. Basically they configured the farm so that all requests to my Orchard app would go through the same server. There was also a problem where I had two bindings: the one with the www. in front and the other without. They had to set-up IIS so that both would go to the same server. It doesn't need to be always the same server but once one is chosen it sticks to it until the app domain times out.

That would also have been fixed by dedicated hosting but that's quite the heavy hammer. You can still share hosting as long as you don't distribute the load too aggressively. At least that was my experience.

Jan 19, 2011 at 7:47 PM

The web farm settings seems like the path to go.  I kept saying that the issue appeared like there was more than one process hitting it, but they never suggested that I might be right.  Did you have to ask special nicely for them to change it?

Coordinator
Jan 19, 2011 at 7:52 PM

All I can say is that I love my hoster. They are very reactive and competent. http://www.adhost.com/ if you must know.

Coordinator
Jan 20, 2011 at 4:22 AM

To go back to the original problem: I started getting System.Net.WebPermissions errors again on my Godaddy account. I applied the workaround mentioned above (Add medium trust entry to web.config) and the problem disappeared.  If someone has an explanation, I'd be glad to hear it.

Wrt to the other problem: I am not seeing deadlocks issues in the log files...

Jan 24, 2011 at 10:03 PM

All issues with GoDaddy are resolved, except that data access is so slow that I still get timeouts on *many* admin requests.  Viewing the blog is a bit slow, but usually works, but anything with updates/inserts is almost unusable.  Is there optimization to be done with indexes, prepared queries, etc.?  It's hard to imagine that a shared GoDaddy host could be this slow.