Login Timeout

Jan 17, 2011 at 2:38 PM
Edited Jan 17, 2011 at 2:40 PM

When I log in to my Orchard website, it will automatically log me out in less than 10 sec.  On my development machine everything works fine, but when I deploy it to my webhosting server (WinHost.com), the problem ocures. When I want to do any action (e.g. add new blog) I'am redirected to login page. When I log in again, the Create New Blog page will appear and if I'am quick enough, I can add a new blog, if not, I am back on login page. I tryed to set  forms timeout="300" and system.transactions/defaultSettings timeout="05:30:00" in web config, but without any noticable change. Any idea what's wrong? I can get to all functionality Orchard offers, but I have to keep logging in again and again. Thanks for any idea.

PS: my provider is in diferent Time Zone (+3 hours) but I do not thing that's the problem

Coordinator
Jan 17, 2011 at 6:53 PM

We're just using forms auth so it's probably not caused by Orchard code but more likely by something in your web site's configuration. It would be interesting to watch the traffic with a network analyzer such as Fiddler and look at the request and response headers for dates that look wrong. The time zone could play a role in that.

Jan 18, 2011 at 7:44 AM

Thank you for your advice, I will try the Fiddler and we'll see.

Jul 26, 2011 at 9:31 PM

Was there any resolution for this issue? I am having the same problem and am using WinHost.com as well..

Thanks

Coordinator
Jul 26, 2011 at 9:33 PM

#1 thing to try with such symptoms is to specify a machine key in config: http://orchardproject.net/docs/Setting-up-a-machine-key.ashx

Jul 26, 2011 at 9:39 PM

Ok, I'll give it a shot. Thanks for the quick reply and I'd like to say great job to you and the rest of the team. I'm really liking the software and how organized the solution is.

Thanks again

Jul 27, 2011 at 6:58 AM
bertrandleroy wrote:

#1 thing to try with such symptoms is to specify a machine key in config: http://orchardproject.net/docs/Setting-up-a-machine-key.ashx


This solved the problem, thanks! I use WinHost as well. For the benefit of those not too familiar with IIS manager, needed to specify the machine key, winhost provides this useful FAQ: http://support.winhost.com/KB/a628/using-the-microsoft-iis-70-manager.aspx

 

Jul 27, 2011 at 4:58 PM

Yup, that worked...thanks everyone for the help!