0.9.253 missing manifest file?

Jan 3, 2011 at 11:05 AM
Edited Jan 3, 2011 at 3:05 PM

I've just installed the 0.9.253 version and when installing a new theme, by zip file, I get:

"Uploading module package failed: Package does not contain a manifest."


The zip worked fine in v0.8, for example, testerTheme.zip, manifest: testerTheme\Theme.txt

Help appreciated.

 

update:

- pasting theme folder to themes installation path works fine. are there any new validations on the installer?

- even if I zip "TheThemeMachine" and try to upload it, I get the error message above

- css file Styles\site.css is not acessible, unless I add a web.config file (behavior changed from v0.8)

I have another question I'd like to see solved: Is there any way I can do someting like @Display(Model.MyZone) or @Display(MyZone) where MyZone is a new Zone defined in the theme?

Coordinator
Jan 3, 2011 at 3:39 PM

That sounds like a bug. Can you please file it in the issue tracker?

about your question, yes you can introduce your own zones.

Jan 3, 2011 at 3:41 PM

I'll file it.

 

About the zones.

How exactly can I add my custom zones in a theme so they show up?

Thanks.

Coordinator
Jan 3, 2011 at 3:44 PM

Pretty much the way you said, except that you also need to declare it in the manifest. Look at the theme machine (layout and manifest) for an example.