Layer Rule for TheHomepage

Nov 28, 2010 at 7:17 AM

Maybe it is because it is after 3 a.m. but it seems the canned Layer for TheHomepage with Layer Rule: url "~/" does not seem to work if the site is in a sub-directory such as http://localhost/Orchard.  Oddly, all other rules do work, such as url "~/about" will properly show its widgets.

Any thoughts?

Nov 28, 2010 at 7:25 AM

Actually it works fine. Maybe what you're seeing is this:

Nov 28, 2010 at 7:30 AM

Maybe they are one in the same? TheHomepage layer rule works fine if I deploy the site to http://localhost but not if I deploy it to a sub-directory.

Nov 28, 2010 at 7:33 AM

What build is that?

Nov 28, 2010 at 7:36 AM

I downloaded this today: from here:

But I just noticed the advisory says 0.8.51 is latest?

Nov 28, 2010 at 7:45 AM

It's the latest release but there are more recent dev builds where this is fixed. (I also fixed the advisory to point to 0.8.201)

Dec 21, 2010 at 10:31 AM

I've tried to fix this problem by creating an new layer (for the widgets) and use the accordant rules - nothing works. My home is //localhost/orchard/" and I tried any variation of this, for example url "~/orchard/" and so on...

The most annoying thing is that there's obviosly no way to edit oder delete these created layers? Any idea? I use the 0.8.201

Dec 21, 2010 at 7:48 PM

This definitely work in the current 0.9 release.

And yes, there is a Delete button in the layer property admin page, which you access by clicking the icon on the left of the layer name.