Orchard.Email project failed to load

Oct 27, 2010 at 2:06 PM

When I opened the Orchard solution in VS2010 Ultimate I got this error

error  : The project file 'Orchard.Web\Modules\Orchard.Email\Orchard.Email.csproj' cannot be opened.

The project type is not supported by this installation.

Previous version 0.5 didn't have this issue. 

Oct 27, 2010 at 9:23 PM

I am having the same issue. I installed ASP.net MVC 1.0 to see if this would have any effect since I already had 2.0 installed.

Coordinator
Oct 27, 2010 at 9:24 PM

Do you have MVC 3 installed?

Oct 27, 2010 at 9:30 PM

No. I wasn't sure if this was a requirement for 0.8. I'll load it now.

Thanks

Coordinator
Oct 27, 2010 at 9:32 PM

Cool, let us know how it goes. Seeing how often this pops up, I'll update the release notes to mention it.

Coordinator
Oct 27, 2010 at 9:40 PM

This is something we are aware about. I will provide a patch to the default branch really soon. It's already corrected on the dev, but as it seems to block a lot of users, we will apply it also on the default.

Oct 27, 2010 at 10:00 PM

Ok, I installed MVC 3.0 and it's working fine.

Installing MVC 3.0 is going to be a horror if you are trying to use Web Platform Installer 3.0 'cause you'll get something like “The product that you are trying to install is not supported on your operating system.  Click here for more information.”.

You should manual download MVC 3.0 installer. Nothing like a good old download. Out of the box things are always buggy.

Oct 27, 2010 at 10:47 PM

Yep, we're good.

Run the AspNetWebPages.msi prior to installing via the AspNetMVC3Setup.exe if you receive an error stating that you need to install ASP.net Web Pages 1.0.  I also cannot recommend the Web Platform Installer. Here is the direct link:  http://www.microsoft.com/downloads/en/details.aspx?FamilyID=0abac7a3-b302-4644-bd43-febf300b2c51&displaylang=en