This project is read-only.

command package create failing

Oct 15, 2010 at 12:26 PM
Edited Oct 15, 2010 at 2:07 PM


I am trying to create a module package to upload and install on to Azure hosted Orchard. While using command (package create <modulename>) at local development desktop I am getting following error. I am getting same error for 0.5 build as well as current dev build. Is there any alternative for packaging and installing the modules? I get this error for all the modules. I still see a zip package created in the bin folder though. While I could upload/install few small modules to Azure deploy, one bigger module (around 5MB package size, which has dependency on 2 other modules which got installed) fails to install. This is the error I am getting while creating package - 

orchard> package create Orchard.Address

AppDomain of Orchard session has been unloaded. (Retrying...)

Initializing Orchard session. (This might take a few seconds...)

AppDomain of Orchard session has been unloaded. (Retrying...)Command returned non-zero result: 240

Thanks for your help. 

Thanks & Regards,


Oct 15, 2010 at 4:51 PM

Can you file a bug in the issue tracker? We're doing lots of stabilization work currently and that sounds like one we should fix for the next release if it's confirmed. Thanks for reporting this.

Oct 15, 2010 at 4:52 PM

Oh, actually, can you run any commands at all?

Oct 15, 2010 at 5:35 PM

Yes, I can run other commands. After command failed, I checked in the bin, and saw the zip file there (inspite of getting error). I could upload and install modules all but one. The one which I could not install is 5mb in size. once upload completes, I get connection error. 

Thanks & Regards,



Oct 15, 2010 at 6:30 PM

Try running orchard.exe from one directory up instead of straight from the bin folder. The package dropping into the bin folder I'm thinking could be causing an app domain restart.

Oct 15, 2010 at 8:24 PM

Thanks infinitiesloop. Running orchard.exe from one director up instead of bin worked. 

Now I have issue with installing module package. Creating new discussion for that. Thanks.