ClickToBuildAzurePackage.cmd gives this error

Oct 11, 2010 at 6:57 PM
Edited Oct 11, 2010 at 6:57 PM

Hi,

I am trying to build Azure package using ClickToBuildAzurePackage.cmd. I am getting following error, what might be wrong here? Thanks for your help.

C:\CLProjects\OrchardDEV\lib\nunit\nunit-console.exe /nologo C:\CLProjects\Or  chardDEV\build\Compile\Orchard.Azure.Tests.dll  ProcessModel: Default    DomainUsage: Single  Execution Runtime: net-4.0.30319.1  

Could not load file or assembly 'Orchard.Azure.Tests' or one of its dependenc  ies. The system cannot find the file specified.C:\CLProjects\OrchardDEV\AzurePackage.proj(69,3):

error MSB6006: "nunit-console.exe" exited with code -2.Done Building Project "C:\CLProjects\OrchardDEV\AzurePackage.proj" (Build target(s)) -- FAILED.

Build FAILED.

 

Thanks & Regards,

Ajay

Coordinator
Oct 11, 2010 at 8:49 PM

This as been corrected in the dev branch, you should change the Microsoft.CloudService.targets location in the file AzurePackage.proj like this:

<Import Project="$(MSBuildExtensionsPath)\Microsoft\Cloud Service\1.0\Visual Studio 10.0\Microsoft.CloudService.targets" />

Oct 12, 2010 at 3:07 AM

Now, I am getting different error. I have taken latest Dev-tip. - 

 

Done Building Project "C:\CLProjects\OrchardDEV\src\Orchard.Azure\Orchard.Azure.CloudService.sln" (Build target(s)) -- FAILED.
Done Building Project "C:\CLProjects\OrchardDEV\AzurePackage.proj" (Build target(s)) -- FAILED.

Build FAILED.
"C:\CLProjects\OrchardDEV\AzurePackage.proj" (Build target) (1) ->"C:\CLProjects\OrchardDEV\src\Orchard.Azure\Orchard.Azure.CloudService.sln" (Build target) (2:2) ->"C:\CLProjects\OrchardDEV\src\Orchard.Azure\Orchard.Azure.CloudService\Orchard.Azure.CloudService.ccproj" (default target) (31:2) ->"C:\CLProjects\OrchardDEV\src\Orchard.Azure\Orchard.Azure.Web\Orchard.Azure.Web.csproj" (default target) (30:3) ->"C:\CLProjects\OrchardDEV\src\Orchard.Web\Core\Orchard.Core.csproj" (default target) (4:18) ->(_CopyWebApplicationLegacy target) ->  C:\Program Files\MSBuild\Microsoft\VisualStudio\v10.0\WebApplications\Microsoft.WebApplication.targets(177,5): error MSB3021: Unable to copy file "Routable\Views\Parts\Routable.RoutePart.cshtml" to "C:\CLProjects\OrchardDEV\build\Compile\_PublishedWebsites\Orchard.Core\Routable\Views\Parts\Routable.RoutePart.cshtml". Could not find file 'Routable\Views\Parts\Routable.RoutePart.cshtml'. [C:\CLProjects\OrchardDEV\src\Orchard.Web\Core\Orchard.Core.csproj]
    0 Warning(s)    1 Error(s)

 

Thanks & Regards,

Ajay

Coordinator
Oct 12, 2010 at 3:23 PM

The current dev branch doesn't work with Azure. I currently trying to get it back.